Commit dc87803d authored by Bruce Flynn's avatar Bruce Flynn

tweaks to Dockerfile

parent df113a71
**/*/__pycache__
......@@ -2,11 +2,12 @@ FROM debian
# minimal deps required to install miniconda and compile py-exts
RUN apt-get update && apt-get -y install \
bzip2 \
curl \
gcc \
git \
libx11-6
bzip2 \
curl \
gcc \
git \
libx11-6 \
&& rm -rf /var/lib/apt/lists/*
# install Miniconda3
WORKDIR /tmp
......@@ -23,8 +24,8 @@ ENV PATH /miniconda/bin:$PATH
RUN mkdir /code
WORKDIR /code
COPY requirements.txt /code
RUN pip install -r requirements.txt
COPY requirements.txt /tmp/requirements.txt
RUN pip install -r /tmp/requirements.txt
COPY stations.yaml /code
COPY amrc_aws /code/amrc_aws
......@@ -35,7 +36,3 @@ COPY .git /code/.git
RUN pip install -e ".[testing]"
COPY tests /code/tests
RUN find /code -name __pycache__ | xargs -n1 rm -rf
RUN apt-get clean && rm -rf /var/lib/apt/lists/* /tmp/* /var/tmp/*
RUN conda clean -y --all
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment