Unverified Commit 7d8cded5 authored by David Hoese's avatar David Hoese Committed by GitHub
Browse files

Fix minimum python version to 3.7 (#328)

* Fix minimum python version to 3.7

* Update website CI to use pre-release of funcparserlib

* Update website CI to use pre-release of funcparserlib - add -U
parent 48bb6015
......@@ -51,6 +51,7 @@ jobs:
shell: bash -l {0}
run: |
pip install sphinx sphinx_rtd_theme sphinxcontrib-apidoc sphinxcontrib-seqdiag sphinxcontrib-blockdiag blockdiag
pip install -U --pre funcparserlib
pip install --no-deps -e .
- name: Run Sphinx Build
......
......@@ -198,7 +198,7 @@ setup(
'pygrib;sys_platform=="linux" or sys_platform=="darwin"', 'imageio', 'pyqt5>=5.9'
],
tests_requires=['pytest', 'pytest-qt', 'pytest-mock'],
python_requires='>=3.6',
python_requires='>=3.7',
extras_require=extras_require,
packages=find_packages(),
entry_points={
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment